Issue with .CO registry

Incident Report for CentralNic Reseller

Resolved

Dear customers,

Recently we experience a short-time outage with .CO registry services. This issue was fixed by our technical team and it should work properly for now. We appreciate you being our customers and apologize for these inconveniences.

Your patience and understanding are most appreciated.
Posted Oct 31, 2025 - 20:26 UTC
This incident affected: Registry.